[ensembl-dev] Installing local copy of ensembl on WINDOWS!

Andreas Kahari ak at ebi.ac.uk
Wed Oct 27 13:43:05 BST 2010

On Wed, Oct 27, 2010 at 01:26:57PM +0100, Andrea Edwards wrote:
> Hi

Hi Andrea

> I'm trying to install a local copy of ensembl on windows as a

Do you mean the Ensembl databases together with the APIs and web-site,
or just the databases?  If you just want to install the databases (or a
single one), there should be no problem.  The API and web-site, however,
is another issue.  In fact, I don't quite know if I've seen anyone
running the web-site on a Windows machine, although the API(s) ought
to work as long as you have some kind of Perl for Windows installed
together with the required modules.

> temporary measure as I'm trying some ideas out and I'm far quicker
> in windows. Anyway I've downloaded my database and created the
> tables and trying to import the data using mysqlimport and I was
> worried the import wasn't working properly because the files were
> created in unix and have \N as the newline character.

The "\N" you see is how NULL is represented in a table dump.  It does
not mean newline.

> I tried the first 2 tables analysis and analysis description and it
> said they had inserted 39 rows in both which I thought seemed
> promising and I could retrieve the rows via the command line using a
> select statement. However when I tried ot look at the tables in
> MySQL query browswer it wasn't happy with the analysis table. It
> said it had 39 rows in it from a count statement
> SELECT * FROM bos_taurus_core_59_4h.analysis a;
> but it couldn't retrieve any data from a select * statement. It
> didn't even retrieve the column headings like you normally get for
> an empty data set. I could retrieve lists of columns though
> e.g. select analysis_id, created from analysis was ok
> I thought this was really odd.
> I deleted the data and tried again. This time

I'm sorry, but I don't know anything about the MySQL query browser
you're using.  A count of the number of rows in a table is usually done
with "SELECT COUNT(*) FROM ...". If you got data from your SELECT, then
it's probably ok.  The query browser is doing something wrong, or you're
using it wrong.

The following is wrong (since "\N" are not newlines).


> I added --lines-terminated-by='\N'  to my import statement to work
> around this and tried it on the first few tables
> C:\>mysqlimport -ppassword bos_taurus_core_59_4h C:/analysis.txt  -u
> root --line
> s-terminated-by='\N'
> bos_taurus_core_59_4h.analysis: Records: 1  Deleted: 0  Skipped: 0
> Warnings: 0
> but I don't think this worked as every table has one row.
> I don't know if these problems are because I am using windows or
> something else altogether!
> Many thanks
> _______________________________________________
> Dev mailing list
> Dev at ensembl.org
> http://lists.ensembl.org/mailman/listinfo/dev

Andreas Kähäri, Ensembl Software Developer
European Bioinformatics Institute (EMBL-EBI)
Wellcome Trust Genome Campus
Hinxton, Cambridge CB10 1SD, United Kingdom

More information about the Dev mailing list