[ensembl-dev] Installing local copy of ensembl on WINDOWS!

Andrea Edwards edwardsa at cs.man.ac.uk
Wed Oct 27 13:26:57 BST 2010


I'm trying to install a local copy of ensembl on windows as a temporary 
measure as I'm trying some ideas out and I'm far quicker in windows. 
Anyway I've downloaded my database and created the tables and trying to 
import the data using mysqlimport and I was worried the import wasn't 
working properly because the files were created in unix and have \N as 
the newline character.

I tried the first 2 tables analysis and analysis description and it said 
they had inserted 39 rows in both which I thought seemed promising and I 
could retrieve the rows via the command line using a select statement. 
However when I tried ot look at the tables in MySQL query browswer it 
wasn't happy with the analysis table. It said it had 39 rows in it from 
a count statement
SELECT * FROM bos_taurus_core_59_4h.analysis a;

but it couldn't retrieve any data from a select * statement. It didn't 
even retrieve the column headings like you normally get for an empty 
data set. I could retrieve lists of columns though

e.g. select analysis_id, created from analysis was ok

I thought this was really odd.

I deleted the data and tried again. This time
I added --lines-terminated-by='\N'  to my import statement to work 
around this and tried it on the first few tables

C:\>mysqlimport -ppassword bos_taurus_core_59_4h C:/analysis.txt  -u 
root --line
bos_taurus_core_59_4h.analysis: Records: 1  Deleted: 0  Skipped: 0  
Warnings: 0

but I don't think this worked as every table has one row.

I don't know if these problems are because I am using windows or 
something else altogether!

Many thanks

More information about the Dev mailing list